CVE-2026-111497

Publication date 23 October 2026

Last updated 26 October 2026


Ubuntu priority

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Read the notes from the security team

Status

Package Ubuntu Release Status
brotli 26.10 stonking
Fixed in 1.2.0-4ubuntu0.1
26.04 LTS resolute
Fixed in 1.2.0-3ubuntu0.1
24.04 LTS noble
Fixed in 1.1.0-2ubuntu0.1
22.04 LTS jammy
Fixed in 1.0.9-2ubuntu0.1
20.04 LTS focal
Needs evaluation
18.04 LTS bionic
Needs evaluation
16.04 LTS xenial
Needs evaluation
nodejs 26.10 stonking
Not affected
26.04 LTS resolute
Not affected
24.04 LTS noble
Not affected
22.04 LTS jammy
Not affected
20.04 LTS focal
Vulnerable
18.04 LTS bionic
Not affected
16.04 LTS xenial
Not affected
14.04 LTS trusty
Not affected

Notes


mdeslaur

nodejs on jammy and higher uses the system brotli, marking as not-affected nodejs on focal uses the vendored brotli nodejs in bionic and earlier doesn't use brotli at all

Patch details

For informational purposes only. We recommend not to cherry-pick updates. How can I get the fixes?

Package Patch details
brotli

Severity score breakdown

CVSS version: CVSS v4.0

Base score 9.2 · Critical

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N


Access our resources on patching vulnerabilities